Critical Upgrade Required to Continue Using Salesforce for Outlook

To avoid service disruption, all Salesforce for Outlook users must be working from version 3.0.0 or later by July 2017. At that time, Salesforce disables TLS 1.0 security encryption protocol, and Salesforce for Outlook v2.9.3 and earlier no longer functions. Reps working from those versions can’t sync their Microsoft® Outlook® items to Salesforce nor can they work with their Salesforce records from the side panel. Make sure that your sales teams upgrade as soon as possible to work through any installation issues before July. This change applies to both Lightning Experience and Salesforce Classic.

In addition, make sure that your reps meet all Salesforce for Outlook requirements for TLS 1.1 and 1.2 compatibility. If you’re not sure which Salesforce for Outlook versions your reps are working from, check from Salesforce.