Salesforce for Outlook: Critical Upgrade Required, Next-Generation Products Available

Our installable Microsoft® integration product is still available for sales teams working from older versions of Microsoft applications. However, if you meet the system requirements for our latest Microsoft integrations, Lightning for Outlook and Lightning Sync, we encourage you to migrate to those products now. That way, you can take advantage of the latest features and avoid manual upgrades in the future. And if you don’t meet the system requirements for our next-generation products, to avoid service disruptions, make sure to read about the pending changes to Salesforce for Outlook system requirements. These changes apply to both Lightning Experience and Salesforce Classic.
This feature available to manage from: both Salesforce Classic and Lightning Experience
Available in: All Editions